Newsleecher 4.0 Final process don't die on application close

Found a bug in NewsLeecher? Post a bug report here. Please describe how to reproduce the bug.
• Be sure to read the bug reporting guidelines before posting.
Mr_Furious
Posts: 4
Joined: Thu Jun 15, 2006 3:35 pm
Location: Sweden

Newsleecher 4.0 Final process don't die on application close

Post by Mr_Furious » Wed Dec 08, 2010 11:45 am

Hi,
I have noticed that after I close newsleecher application the newsleecher.exe process stays in the task manager and starts using all cpu from one core.
I have to manually kill the process.

This is new behaviour since installing version 4 final and I did not see anything like this before with the Betas for version 4.

I am running a 64-bit Windows 7.

Anyone else seeing the same? Or is this normal? I have not waited more than 3-4 minutes before I kill the process, but still if it was part of some standard garbage collection it seems strange.

During normal operation of Newsleecher I don't see anything weird and it does not consume any cpu unless actively downloading or verifying/extracting.. Only after I close the application this happens.

Mr_Furious
Posts: 4
Joined: Thu Jun 15, 2006 3:35 pm
Location: Sweden

Post by Mr_Furious » Wed Dec 08, 2010 1:20 pm

Reinstalled the final version on top of the one already installed and that seems to have helped.

Turles
Posts: 10
Joined: Tue Sep 26, 2006 3:32 pm

Post by Turles » Thu Dec 16, 2010 1:04 pm

I also have this same issue happening, same setup as well: 64-bit Win7. Have not tried reinstalling yet though but will give that a go.

klickeklick
Posts: 14
Joined: Mon Oct 01, 2007 8:15 pm

Post by klickeklick » Sun Dec 19, 2010 6:01 am

Having the same issue. I think it started with one of the last beta builds before going Final. The process won't close and then uses all the CPU. AMD 64bit Dual Core Mobile, Win 7 64bit. It doesn't do it every time though, so making it kinda hard to pin point a conflict. Re-Install did not help and I am pretty sure it started during the last builds after Nov 20th. I may try a clean uninstall later this week.

nevermind
Posts: 9
Joined: Sun Dec 19, 2010 11:01 am

App Hang when closing application

Post by nevermind » Sun Dec 19, 2010 11:15 am

Version: 4.0 final
Operating System Windows 7 32Bit Ultimate
Installation Method: Upgrade
Type of Installation: Registered
Number of Servers: 1
Connections per server: 40

Since i've installed the 4.0 final everytime i try to close the application i've got an error message from Windows and the process still appears in task list with a cpu percentage of ~ 25%. And i have to kill the process manually.

Image
Reinstalled the final version on top of the one already installed
didn't work for me.

xiaNaix
Posts: 9
Joined: Sat Dec 09, 2006 10:23 am

Post by xiaNaix » Wed Dec 22, 2010 4:23 am

I was having the same problem on Win7 Pro 64-bit. I set newsleecher.exe to run in compatibility mode for Vista SP2 and it seems to have solved it.

klickeklick
Posts: 14
Joined: Mon Oct 01, 2007 8:15 pm

Post by klickeklick » Wed Dec 22, 2010 7:45 pm

I might just have something with super search. All I did today was use the search, closed the NL app and it was hung closing 100% CPU. Replicated twice. Will test further this weekend.

Dibbler
Posts: 85
Joined: Sat Jul 10, 2004 7:55 pm

Post by Dibbler » Thu Dec 23, 2010 3:07 pm

Mine is the same....

Problem Event Name: APPCRASH
Application Name: newsLeecher.exe
Application Version: 0.0.0.0
Application Timestamp: 4cf4caa4
Fault Module Name: newsLeecher.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4cf4caa4
Exception Code: c0000005
Exception Offset: 00005a9a
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 2057
Additional Information 1: 700c
Additional Information 2: 700cd9bda2fcdbb4b35a0f20b3a2e896
Additional Information 3: 7a00
Additional Information 4: 7a00f4ab7973dad8e382afcefb35e955



Windows 7x64 with a complete fresh install.

It also keeps running in the memory at 50% util and has to be ended via task manager

klickeklick
Posts: 14
Joined: Mon Oct 01, 2007 8:15 pm

Post by klickeklick » Fri Dec 24, 2010 5:23 am

Ok if I just open and close NL without clicking anything else it hangs when closing. There is a hidden window that is waiting for clicking Ok. Found it with Spy++ Here is the error message.
Runtime error 216 at 00405A9A
Old MS articles refer to the old subseven virus, doubtful. This is also an error with registry access problems. Is there a NewsLeecher cleaner / uninstaller to wipe all the registry settings and files? I had to update my license around the same time I noticed this becoming a problem.

User avatar
Smudge
Site Admin
Posts: 10034
Joined: Tue Aug 17, 2004 1:42 am

Post by Smudge » Fri Dec 24, 2010 7:25 am

The only registry entry that NewsLeecher uses is to save the license key. You can try deleting the entry from the registry just in case there is some permission issue or something going on.

Open the RegEdit program and delete the Crystal Art Software entry from the HKEY_CURRENT_USER/Software/ hive.
Please be aware of and use the following pages...
Services Status Page : SuperSearch and Usenet Access server status, retention, server load, indexing time, etc.
Support Request Form : Use this if you have a problem with billing or account status. The forum is only for NewsLeecher application issues.

klickeklick
Posts: 14
Joined: Mon Oct 01, 2007 8:15 pm

Post by klickeklick » Fri Dec 24, 2010 8:08 am

Nope that didn't help. I cleared that key and changed the member area password to make sure it was cleared. Restarted NL, accepted the userid/passwd, new key was created. Closed NL and it did the same thing. Took a look at how many threads were open before closing and when it hangs. 8 threads of the 40 that opened were able to close. The GUI and taskbar icon disappear like NL has closed but the CPU spikes soon after the GUI closes.

xiaNaix
Posts: 9
Joined: Sat Dec 09, 2006 10:23 am

Post by xiaNaix » Sat Dec 25, 2010 9:19 pm

Have you tried setting newsleecher.exe to run in compatibility mode for Vista? That solved it for me. Haven't had a process issue since.

klickeklick
Posts: 14
Joined: Mon Oct 01, 2007 8:15 pm

Post by klickeklick » Sat Dec 25, 2010 11:06 pm

xiaNaix wrote:Have you tried setting newsleecher.exe to run in compatibility mode for Vista? That solved it for me. Haven't had a process issue since.
Will try that soon but really the app shouldn't need this setting.
I extracted out all the last versions of NL Beta RC builds and running outside of the normal install folder. Trying to replicate the problem and so far it's not tripin out. As soon as I run the current version in the install folder, it trips out. If I copy that folder to the %ProgramFiles(x86)% it trips out. Permissions are the same as every other folder and file in the %ProgramFiles(x86)% location. So I tested all the other beta RC builds in the %ProgramFiles(x86)% and none of them would trip with-in 3 attempts. I was pretty sure one of the last beta RC builds it was doing it but maybe not. Going to run Beta 24 RC for a while and see if it does it. I can replicate the error just starting and closing the Final build every time. If I download something, it normally closes. If I search for something and close, it hangs on exit. If I start and close, it hangs every time.
Maybe a problem with the exe protector or a new bug introduced in the final. Whatever changed between Beta24 and Final...

nevermind
Posts: 9
Joined: Sun Dec 19, 2010 11:01 am

Post by nevermind » Sun Dec 26, 2010 12:45 pm

xiaNaix wrote:Have you tried setting newsleecher.exe to run in compatibility mode for Vista? That solved it for me. Haven't had a process issue since.
Haven't tried this since i pay for NewsLeecher. And for payed software I expect a bugfree app to run with the latest OS. Windows 7 is out for 2 years now (incl. the Beta for testing) The last sentence on the Home page of newsleecher is
Compatible with Windows 98, Me, NT, 2000, 2003, XP, Vista and Windows 7
The most annyoning thing is that additionally the 'An Application bug has occoured' is back too. For a so called 'Final' this is really poor. As a software engineer I think the app suffers on "Featuritis"

From now, I will wait exactly one month for a fixed version. Otherwise I finish my 2 year relationship with NewsLeecher. There is other software out there...

sheepshagger
Posts: 457
Joined: Thu Aug 16, 2007 4:00 pm

Post by sheepshagger » Mon Dec 27, 2010 2:39 am

ever thought its something local on your machine?

i have no issues that people are reporting, what antivirus and firewall do you use? it is possible that either one is trying to intercept data and keeps files open for scanning and isnt closing it down properly

Post Reply