Password Manager doesnt extract but correct password is in the list

Found a bug in NewsLeecher? Post a bug report here. Please describe how to reproduce the bug.
• Be sure to read the bug reporting guidelines before posting.
Post Reply
writer
Posts: 2
Joined: Thu Jan 23, 2014 7:57 pm

Password Manager doesnt extract but correct password is in the list

Post by writer »

Hi,

I just figured out that the last password in the list is obviously not used to extract the files. I couldn't download a certain file (got spam warnings) but as soon as I added another password ("xx" to have it at the end of the list) it worked.

Just wanted you to know.

Another thing: It might be a nice feature if one could overrule the download-stop after a spam warning by choosing "resume selected". What do you think?

KR

User avatar
Spiril
Site Admin
Posts: 4278
Joined: Fri Nov 07, 2003 3:11 am

Post by Spiril »

I'm pretty sure that bug got fixed recently.

Are you using the latest beta release ? If not, try to download it and see if it works.
bug fixed. no idea how. hate it when that happens. trying to break it again now. will. not. be. defeated.

writer
Posts: 2
Joined: Thu Jan 23, 2014 7:57 pm

Post by writer »

Hi,

yes - I'm using v6.5 Beta 1.
I know that there was an issue with the first password in the list. You suggested to insert a password "!", which then would be the first in the list, as a workaround before fixing that bug. But in my case the last password seems to be ignored (at least it was missing in the log and the file was marked as spam).

User avatar
Spiril
Site Admin
Posts: 4278
Joined: Fri Nov 07, 2003 3:11 am

Post by Spiril »

Writer,

I think this fixes the bug :

http://www.newsleecher.com/nl65003.ufr1.exe
bug fixed. no idea how. hate it when that happens. trying to break it again now. will. not. be. defeated.

qwad
Posts: 16
Joined: Thu Apr 05, 2007 10:10 pm

Post by qwad »

i'm having a similar issue.

say i add 10 archives to the d/l queue that i know all have the same p/w and i have the correct p/w in the p/w manager, 7 (or more) of them will pause. if i the click 'resume' all 10 will d/l and extract just fine.

i tried turning off the p/w checking but it doesn't turn off either.

the p/w manager is a great feature but it is a bit buggy for no reason that i can see.

any ideas?

Post Reply