Constant Crash When Using Program Latest Beta

Found a bug in NewsLeecher? Post a bug report here. Please describe how to reproduce the bug.
• Be sure to read the bug reporting guidelines before posting.
Post Reply
streetglyden
Posts: 2
Joined: Mon Jun 23, 2014 3:55 pm

Constant Crash When Using Program Latest Beta

Post by streetglyden »

Version: B5
Operating System w/ Service Pack Version: Windows 7 Pro SP1
Installation Method: Upgrade
Type of Installation: Beta
Number of Servers: 1
List your provider(s): Astraweb
List of antivirus/firewall software installed: Symantec Endpoint
Connections per server: Please list connections for each server: 10


Bug Description: Every article that I select to download as soon as I queue it I constantly get this error message

Bug ID:
j9aj98aj

Bug Data #2:
Access violation at address 008218BE in module 'newsLeecher.exe'. Read of address 00000848

User avatar
Bartman1967
Posts: 9
Joined: Thu Dec 19, 2013 2:14 pm

Post by Bartman1967 »

Me too:

Bug ID:
j9aj98aj

Bug Data #2:
Access violation at address 008218BE in module 'newsLeecher.exe'. Read of address 00000848

Gone back to 6.5 beta 4, and have no problems.

Version: 6.5 Beta 5
Operating System w/ Service Pack Version: Windows 7 64bit, all up to date
Installation Method: upgrade
Type of Installation: Beta
Number of Servers: 1
List your provider(s) Tweaknews
List of antivirus/firewall software installed: MSE, and Malwarebytes
Connections per server: 40
Server priority: top

Rubens58
Posts: 27
Joined: Fri Mar 05, 2010 7:04 am

Post by Rubens58 »

Me too.

For every article selected to download as soon as it queued, Newsleecher constantly presents this error message...

Bug ID:
j9aj98aj

Bug Data #2:
Access violation at address 008218BE in module 'newsLeecher.exe'.
Read of address 00000848

-----------------------------------------------

Version: 6.5 Beta 5
Operating System: Windows 7 Ultimate 64bit SP1, all up to date
Installation Method: upgrade
Type of Installation: Beta
Number of Servers: 2
List your provider(s): Astraweb and NewsHosting
List of antivirus/firewall software installed: no antivirus, only Windows Firewall.
Connections per server: 18 for Astraweb + 30 for NewsHosting

Rubens58
Posts: 27
Joined: Fri Mar 05, 2010 7:04 am

Post by Rubens58 »

The author could:

1. Implement ESC key to get rid of these reduplicates and annoying "An Application Bug Has Occured" window messages.

2. Implement an setting option to get rid of ALL these annoying bug error messages.

wvd_vegt
Posts: 58
Joined: Wed Nov 30, 2005 7:06 pm

Post by wvd_vegt »

Same bug here.

Just park the window outside view also works.
wvd_vegt

User avatar
Spiril
Site Admin
Posts: 4278
Joined: Fri Nov 07, 2003 3:11 am

Post by Spiril »

I haven't been able to trigger the bug myself, no matter how much I leech, so it's not an easy fix.

But I have uploaded an unofficial forum release with some extra bug tracking code. If you have the time, pls try it out and let me know what error msg you get :

http://www.newsleecher.com/nl65006ufr1.exe
bug fixed. no idea how. hate it when that happens. trying to break it again now. will. not. be. defeated.

Voyager2k
Posts: 61
Joined: Sat May 01, 2010 8:45 am

Post by Voyager2k »

Same here. It happens as soon as something is added to the queue and it's gone when the queue is empty again. Downloads do work fine (see post in beta releases sub forum, was sleepy and posted there this morning).

Restarting with or without something in the queue isn't helping. Also, the download progress in the queue list isn't shown anymore for the current file. When the file is downloaded it is removed and the window updates. So I am guessing it probably has something to do with the list updates as each individual segment downloads. Possibly :) What do I know ...

I'll try the forum release. Hopefull that provides some additional data for you to work with.

EDIT:

Tried the forum relase and I am terribly sorry to inform you that you will be extremely disappointed because the bug is gone from that release. No more application bug ........

EDIT2: wh00ps, didn't read your sig ... guess it's old news then. my bad.

justjoined
Posts: 1
Joined: Tue Jun 24, 2014 3:00 pm

Post by justjoined »

Howdy, just joined to say I have been getting the constant (literally close one and another pops up) access violation popups, I downloaded and tried your forum release and the problem seems to have gone, so something must have been tweaked as well as adding extra tracking code I guess !
Anyway, thanks !

:)

Rubens58
Posts: 27
Joined: Fri Mar 05, 2010 7:04 am

Post by Rubens58 »

I downloaded and installed the unofficial forum release and the bug is gone.

Thank you for your efforts.

streetglyden
Posts: 2
Joined: Mon Jun 23, 2014 3:55 pm

Post by streetglyden »

Yea I just installed the unofficial forum release and the bug is gone. The other thing I noticed is when I had the crash if I left it open the files would still download but I could not see a percentage. With this release everything looks normal again.

farzadsux
Posts: 1
Joined: Wed Jun 25, 2014 1:23 am

Had bug also

Post by farzadsux »

I had the 6.5b5 bug also. The unofficial release seems to have fixed the problem.

Bug ID:
j9aj98aj

Bug Data #2:
Access violation at address 008218BE in module 'newsLeecher.exe'. Read of address 00000848

User avatar
Spiril
Site Admin
Posts: 4278
Joined: Fri Nov 07, 2003 3:11 am

Post by Spiril »

Voyager2k wrote:wh00ps, didn't read your sig ... guess it's old news then. my bad.
I have had that sig for a long time. So I still have to find out what I actually did to fix the bug ;) Though I have a good idea what fixed it.
bug fixed. no idea how. hate it when that happens. trying to break it again now. will. not. be. defeated.

User avatar
Spiril
Site Admin
Posts: 4278
Joined: Fri Nov 07, 2003 3:11 am

Post by Spiril »

Thank you all for checking the test version. We'll make a new official release with the fix very soon.
bug fixed. no idea how. hate it when that happens. trying to break it again now. will. not. be. defeated.

Post Reply