Page 1 of 1

Lost all groups and headers

Posted: Tue Sep 01, 2009 8:38 am
by capntripz
This is the third time for this problem. I start newsleecher like normal and all the groups and headers are gone. It takes almost a week to get all the headers for my groups, so you can see this is a major frustration. Newsleecher knows who my server is, how many channels to use, etc. It does not show any of the virtual groups, regular groups, and none of the headers that would have been in those groups... Very dissappointed in Newsleecher at this time. Don't want to start over again. Does anyone know of a fix or the cause of this?

Capn.

Posted: Tue Sep 01, 2009 11:19 pm
by Smudge
If the data is disappearing like that, it is usually due to a corrupted configuration/cache file.


You can find the location and explanation of each configuration file at viewtopic.php?t=6766

If you are using 3.95 beta 1 or later, the setup.dat files are backed up automatically so you can use a previous version. They are stored in the %APPDATA%\NewsLeecher\backups\ directory. Replace your corrupted setup.dat with one of these backups, renaming it properly of course.

If that doesn't resolve the problem, try moving all of the .dat files out of the configuration data directory and run NL again. If there error goes away then it was one of those files. You could move a few of the files back in until you find the corrupt file.

Uninstalling and reinstalling will not remove the configuration files.

Loss of external drive cause problem?

Posted: Fri Sep 04, 2009 1:00 am
by capntripz
I am trying to put as much of the storage burden on a USB external drive as my laptop has a smallish C drive. I think this problem crops up when that drive is not available (spun down, unplugged, whatever). Perhaps I am not correctly setting this up. Can you provide some guidance on how I should accomplish this and I will try your advice above and see if everything will pop back into place.

Thanks so much,
Capn.

Posted: Fri Sep 04, 2009 5:19 am
by Smudge
If you are wanting to store the NewsLeecher configuration files on this USB drive, you must have it connected and running before launching NewsLeecher. Best way would be to install the application itself on the drive so that you couldn't even run NewsLeecher if the drive isn't connected.

You can use these instructions to set the location of the configuration files and the temp directory so that it doesn't use the default location on the C drive. I would recommend setting the dataFolder to your USB but leave the tempFolder on the internal C since it will most likely be faster and shouldn't be using that much space anyways. Just configure it to C:\Temp\. It is only used for holding the article segments as they are downloaded but when joined, they are moved to the download directory, which you will most likely have configured to be on the USB drive.

Posted: Fri Sep 04, 2009 12:16 pm
by capntripz
When I install to a different drive letter, will there be any problems with lost pointers or files or will they update to the new drive letter?

That solution is going to work for me.

Thanks,
Capn

Posted: Fri Sep 04, 2009 7:19 pm
by Smudge
Uninstall from the C drive then reinstall on your USB drive (for example X:\NewsLeecher\). Don't run NewsLeecher yet.

Copy the NewsLeecher configuration directory to your USB drive to X:\NewsLeecher\config\. (you will need to rename the NewsLeecher config dir from "NewsLeecher" to "config")

Configure the .ini file in the X:\NewsLeecher directory as
dataFolder=X:\NewsLeecher\config\
tempFolder=C:\Temp\

Posted: Sat Sep 05, 2009 1:25 am
by capntripz
Will do. Thanks again.
Capn.