3.9 beta 2 bugs

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
neilx
Posts: 4
Joined: Fri Mar 30, 2007 10:48 pm

Post by neilx » Fri Apr 13, 2007 7:33 am

Smudge wrote:you need to delete the lvq.dat file from your configuration directory.
thank you very much :D
as he watched the mighty ship sink slowly beneth the waves, he remembered where he left his wallet.

robwas
Posts: 5
Joined: Sun Aug 15, 2004 8:09 pm

RNE problems in b2, deletes files and gets stuck

Post by robwas » Fri Apr 13, 2007 1:57 pm

I've found 2 issues in beta 2, first, and this has happened twice, rne just doesn't like some archives and gets stuck. It says repairing, goes from 0-100% and repeats this process indefinitely, never actually repairing the archive. I ran a separate program and it fixed the archive just fine. Secondly, and more alarming I had several things tagged to download, when i woke up almost all my files were gone that it had downloaded. Here's what I have in my log below. Not sure why it put all these in the recycle bin but it did to this and 4 other downloads.

4/13/2007 1:46:16 AM * Start Extraction : C:\INCOMING\incoming\Rimsky-Korsakov_Suites, Overtures\rimsky-korsakov_cd1.par2
4/13/2007 1:46:16 AM * Folder Src. : C:\INCOMING\incoming\Rimsky-Korsakov_Suites, Overtures\
4/13/2007 1:46:16 AM * Folder Dst. : C:\INCOMING\incoming\Rimsky-Korsakov_Suites, Overtures\
4/13/2007 1:46:16 AM * Archive File #01 : 03. Rimski-Korsakov_Orch. Works_Kapp_Scans.rar
4/13/2007 1:46:16 AM * Extracting : "03. Rimski-Korsakov_Orch. Works_Kapp_Scans.rar".
4/13/2007 1:46:17 AM * Extracted : 2 files.
4/13/2007 1:46:17 AM * Copying Eventual Non-Archive File to Destination ...
4/13/2007 1:46:17 AM > Copying ... : "00. Rimsky-Korsakov_Suites, Overtures_info.txt".
4/13/2007 1:46:17 AM > Copying ... : "01. Rimsky-Korsakov Suites, Overtures, etc. (1 2).LOG".
4/13/2007 1:46:17 AM > Copying ... : "02. Rimsky-Korsakov Suites, Overtures, etc. (1 2) - tracks.CUE".
4/13/2007 1:46:17 AM > Copying ... : "02a. Rimsky-Korsakov Suites, Overtures, etc. (1 2) - image.CUE".
4/13/2007 1:46:17 AM > Copying ... : "101. The Invisible City of Kitezh (suite)- Prelude.flac".
4/13/2007 1:46:17 AM > Copying ... : "102. Bridal Procession.flac".
4/13/2007 1:46:17 AM > Copying ... : "103. The Battle of Kershenetz.flac".
4/13/2007 1:46:17 AM > Copying ... : "104. Apotheosis of Fevronia.flac".
4/13/2007 1:46:17 AM > Copying ... : "105. Mlada (orchestral suite)- Introduction.flac".
4/13/2007 1:46:17 AM > Copying ... : "106. Redowa.flac".
4/13/2007 1:46:17 AM > Copying ... : "107. Lithuanian Dance.flac".
4/13/2007 1:46:17 AM > Copying ... : "108. Indian Dance.flac".
4/13/2007 1:46:17 AM > Copying ... : "109. Cortege.flac".
4/13/2007 1:46:17 AM > Copying ... : "110. May Night (overture).flac".
4/13/2007 1:46:17 AM > Copying ... : "111. Christmas Eve (Suite #2 from the Opera).flac".
4/13/2007 1:46:17 AM * [Recyclebin] - Deleted File Set Files to Recyclebin. (rimsky-korsakov_cd1)

Hecks
Posts: 148
Joined: Wed Apr 05, 2006 9:40 am

Re: RNE problems in b2, deletes files and gets stuck

Post by Hecks » Fri Apr 13, 2007 10:54 pm

robwas wrote: Secondly, and more alarming I had several things tagged to download, when i woke up almost all my files were gone that it had downloaded. Here's what I have in my log below. Not sure why it put all these in the recycle bin but it did to this and 4 other downloads.
*sigh*

RnE will delete any non-rar files if the download folder and the extract folder are set to be the same. This is easily solved by always making sure they are set to be different. Voila.

This is officially the last time I'm posting this solution.

-Hecks

Wintermute
Posts: 9
Joined: Wed Nov 24, 2004 5:54 pm

Post by Wintermute » Sat Apr 14, 2007 5:46 pm

hi,

since a few days in my RnE tab, there is no font anymore. It still works, but the whole window is empty. Maybe a missing font? But I cant remember to deinstall any. Any hint? thx!

robwas
Posts: 5
Joined: Sun Aug 15, 2004 8:09 pm

Post by robwas » Sat Apr 14, 2007 11:58 pm

Sorry Heck, I should have read more before posting. I did change that setting, previously I had it set to a different folder but to make life easier, I was doing all "leech specify" and using extract to the same folder since doing it any other way can create a mess of downloads you may or may not understand. An invaluable feature would be a way to set the name of the final folder after extraction somewhere in the process. Again though, thanks for answering and my apologies for being ignorant.

Rob

FrogDawg
Posts: 6
Joined: Thu Mar 16, 2006 4:17 pm

423 no Such article

Post by FrogDawg » Tue Apr 17, 2007 11:59 am

Hi

I have tried searching before posting and haven't seen anything,
here's my problem, only on this beta I've had this problem:
17/04/2007 08:00:20 ¤ Server response: "423 No Such Article In Group". Part Msg ID: "KNqdne_nfpek9FHYnZ2dnUVZ_oTinZ2d@giganews.com". Part Format: "Unknown".

It's a error that's repeated throughout the rar set, this occurs whether I use a nzb, d/l headers and grab the rar set that way, it doesn't matter whether they're 5 hours or 50 days old too, I have checked with my news providor and there's no probs at there end, eventually I can grab the headers but it takes a reboot etc.. to get started again, this usually occurs like one I read earlier after my connections have randomly dropped with errors:
17/04/2007 07:49:45 Unable to connect / authenticate server: NewsDemon @ europe.newsdemon.com (connect: WSocketResolveHost: Cannot convert host address 'europe.newsdemon.com', Error #11004).
and
17/04/2007 07:59:02 Unable to authenticate at server: NewsDemon (502 Maximum number of connections reached.).
and finally lol
17/04/2007 07:59:42 Resetting hanging connection on the "NewsDemon" server. (21 seconds of inactivity) the inactivity is set to 60!!!

All the headers are d/l upto these errors then it begins.
Was considering going back to beta 1 or the latest final what ya think.
Thanks for any help or suggestions.

FrogDawg

User avatar
BrownGhost
Posts: 10
Joined: Thu Apr 19, 2007 9:54 am

RnE Bug. deleting MP3 files, and 001-> rar files (v3.9 beta 2)

Post by BrownGhost » Thu Apr 19, 2007 10:13 am

Please fix the RnE its deleting files after its finished extracting them Sad
mp3 files
and some times the files if thy are names like
000
001
002 and so on.. (rar files)

Maestro4k
Posts: 6
Joined: Thu Oct 27, 2005 6:07 am

Post by Maestro4k » Fri Apr 20, 2007 11:55 am

RnE appears to have problems if the filenames have too many .'s in them. For example:

xxxxx.xxxx.season.2.vol.4.r1.dvdr-kif.par2

I've been grabbing all the volumes of that release so I have vol.3, vol.2 and vol.1 as well. RnE has one entry named just xxxxx.xxxx.season.2 and only checked volume 1. It also extracted it to a directory named xxxxx.xxxx.season.2 instead xxxxx.xxxx.season2.vol.1.r1.dvdr-kif like you would expect it to. (I have it set to extract to separate subfolders.) I've seen it act like this with one other archive and it also used .'s for word separators.

For Beta 1 it's mentioned that RnE was purposefully ignoring the delete option and moving to the recycle bin but it also mentions this will be corrected later. It's unclear if it was changed for Beta 2 so I thought I'd mention this just in case. Right now the delete option sticks part of the files in the Recycle Bin, but not all of them generally (occasionally it does put the entire thing in there). I figure either way this isn't the expected behavior. :)

Wintermute
Posts: 9
Joined: Wed Nov 24, 2004 5:54 pm

Post by Wintermute » Sat Apr 21, 2007 6:20 pm

Noone experiences my problem as described above? :(
RnE window ist completely empty, but its working. I installed a new version other the old one, but that didn't help.

User avatar
techfuzz
Forum Moderator
Posts: 5377
Joined: Sat Jul 17, 2004 5:25 pm

Post by techfuzz » Sat Apr 21, 2007 10:02 pm

Wintermute wrote:Noone experiences my problem as described above? :(
RnE window ist completely empty, but its working. I installed a new version other the old one, but that didn't help.
Does it only happen in the R'n'E window or are there other areas in NL where the font is missing?

techfuzz

Wintermute
Posts: 9
Joined: Wed Nov 24, 2004 5:54 pm

Post by Wintermute » Sat Apr 21, 2007 10:17 pm

techfuzz wrote: Does it only happen in the R'n'E window or are there other areas in NL where the font is missing?
techfuzz
Only that one. I solved it meanwhile by deleting all lv*.dat files and downgrading to beta1.

User avatar
techfuzz
Forum Moderator
Posts: 5377
Joined: Sat Jul 17, 2004 5:25 pm

Post by techfuzz » Sun Apr 22, 2007 6:10 am

Wintermute wrote:Only that one. I solved it meanwhile by deleting all lv*.dat files and downgrading to beta1.
It was probably a corrupt config file.

techfuzz

User avatar
BrownGhost
Posts: 10
Joined: Thu Apr 19, 2007 9:54 am

BUG: rar password protectet = NL will just hang for ever

Post by BrownGhost » Mon Apr 23, 2007 8:37 pm

if rar files have password. NL RnE should just skib the rar set!

now it just hangs, and one can close it.
one have to force it to close = loosing all data ;(

User avatar
BrownGhost
Posts: 10
Joined: Thu Apr 19, 2007 9:54 am

Bug: NZB file import from folder auto

Post by BrownGhost » Tue Apr 24, 2007 8:57 am

i have set my NL to import NZB files automatically from a folder.
in this folder i download nzb files.

there are 2 problems.

1. NL looks for files in there to often, it should be like every 30 seconds or every 1 minutes or so. as now if a download is to slow it makes a mess of things.

2. some time after it imports a NZB file, the movie im downloading will be called(folder). Movie name.NZB

this makes more problems, as NL thinks this is a NZB file but its not, but it keeps trying to import that folder :(

User avatar
techfuzz
Forum Moderator
Posts: 5377
Joined: Sat Jul 17, 2004 5:25 pm

Re: Bug: NZB file import from folder auto

Post by techfuzz » Wed Apr 25, 2007 7:36 pm

BrownGhost wrote:2. some time after it imports a NZB file, the movie im downloading will be called(folder). Movie name.NZB
It makes the folder "something.nzb" because there is a bug in NL that when you download a NZB file directly to your import directory, it will sometimes get the .part file that Firefox creates as a temporary file for larger files you download. The workaround until this bug is fixed is to download the NZB files to some other directory and then move them to your import directory after they have finished downloading.

techfuzz

Post Reply