RnE will delete correct files upon completion of download (3.9b9+prev)

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
Post Reply
User avatar
eriji
Posts: 54
Joined: Mon Jan 16, 2006 11:27 am
Location: Orangeburg, SC
Contact:

RnE will delete correct files upon completion of download (3.9b9+prev)

Post by eriji » Sun Nov 04, 2007 12:43 am

If the subject is not clear, what happens is if you have RnE set to monitor, verify, extract, etc, at the time it does this, it will delete all the verified files i.e. all the good files.

I've got two situations of this right now.

#1 A set of sequentially named .zip files. A .par2 file was associated with them and they are all there. RnE does it's thing (and I didn't expect it to extract the files, since it doesn't handle the most popular archive, .zip) and my expectations are that it would verify the files, say "yea, they're all there" and then be done with it. NOPE, it does it's thing, says finished, and low and behold, the verified GOOD files are now in the recycle bin. I retrieve them from the recycle bin, and QuickPar verifies them ok.

#2 A set of .mp3 files with a .par2 file associated. Same thing. RnE says finished, and the files are moved to the recycle bin. This time I had QuickPar running in tandem with the download, and the files verified there, and then were removed by RnE to the recycle bin.

This seems like a serious (and serial) bug. I've seen it before on previous betas, but never actually followed it through.

At least, this time RnE didn't go into a loop as it did here:
viewtopic.php?t=14343

I'm set to Enabled, Verify, Repair, Extract, Monitor and
Auto Unpause, Extract to the same folder, After SuckSess Extraction-
Move Archive and Par2 to Recycle Bin, remove any excess par2 files from queue. (the latter, it did do.)

PM me for details on the files if wanted.

User avatar
eriji
Posts: 54
Joined: Mon Jan 16, 2006 11:27 am
Location: Orangeburg, SC
Contact:

Post by eriji » Sun Nov 04, 2007 1:41 am

Sorry**, this has been reported several times, and smudge says it will be corrected before 3.9 final.

Look here:
viewtopic.php?t=15087&highlight=rne+delete

And at the original topic thread that smudge references:
3.9 Beta 1 with Repair'n'Extract
viewtopic.php?t=12628


**Eye gess I skr'd up. Mebbe must have miss-typed my search turms wen I tryd to fined et urlir b4 posten.

User avatar
Smudge
Site Admin
Posts: 10034
Joined: Tue Aug 17, 2004 1:42 am

Post by Smudge » Mon Nov 05, 2007 6:36 am

Can you please send a PM to Spiril with the information of the usenet post that you were having a problem with. This example will help him track down this problem.
Please be aware of and use the following pages...
Services Status Page : SuperSearch and Usenet Access server status, retention, server load, indexing time, etc.
Support Request Form : Use this if you have a problem with billing or account status. The forum is only for NewsLeecher application issues.

User avatar
eriji
Posts: 54
Joined: Mon Jan 16, 2006 11:27 am
Location: Orangeburg, SC
Contact:

Post by eriji » Mon Nov 05, 2007 10:13 pm

Done.

Koogle

Post by Koogle » Wed Nov 07, 2007 2:02 pm

man what a screw up!!!! i just lost over 5gb worth of overnight download because of that extract option.. i thought i'd leave it on so the download was extracted for me... only to find an empty folder and only a few of the files left in the recycle bin..

jeesh why not make it more obvious to users that RnE has these kind of problems!!!

User avatar
techfuzz
Forum Moderator
Posts: 5377
Joined: Sat Jul 17, 2004 5:25 pm

Post by techfuzz » Wed Nov 07, 2007 6:57 pm

Koogle wrote:jeesh why not make it more obvious to users that RnE has these kind of problems!!!
Koogle, you are currently using BETA versions of NL. There is no warranty or implied expectation that it will function correctly. We suggest you use the last final released version (v3.8) until a new final version (v3.9) is made available.

techfuzz

Hecks
Posts: 148
Joined: Wed Apr 05, 2006 9:40 am

Post by Hecks » Wed Nov 07, 2007 9:00 pm

techfuzz wrote:
Koogle wrote:jeesh why not make it more obvious to users that RnE has these kind of problems!!!
Koogle, you are currently using BETA versions of NL. There is no warranty or implied expectation that it will function correctly. We suggest you use the last final released version (v3.8) until a new final version (v3.9) is made available.

techfuzz
There's absolutely no excuse for this bug still not to have fixed *ten months* later. Plenty of alternative newsreaders, including free ones, are able to handle this very basic functionality just fine. Why not Newsleecher? Really I'm starting to think that these betas (access to which is a privelege that users have to pay for, of course) are deliberately being kept crippled until the 12 month mark, which guarantees that everyone will have to upgrade their license to get properly functioning RnE.

I'm sorry techfuzz, I wouldn't have posted this ordinarily, but your 'corporate' response was just really lame. Sad what Newsleecher has come to. :(

Post Reply