NewsLeecher V4.0 Beta 3 Issues

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
talon95
Posts: 3
Joined: Tue Apr 07, 2009 11:26 am

Pauses and Lockups

Post by talon95 »

I just did a clean install of Windows 7 RC 7100 64bit and Newsleecher 4 Beta 3. Immediately on initial startup Newsleecher hangs for about 30 seconds. After this it appears to work, but randomly locks up (does not recover) when downloading headers.

I've seen quite a few comments about this in other threads, but no resolution.

wielk
Posts: 16
Joined: Tue Dec 07, 2004 10:50 pm

NZB gives problem with NL 4.0 beta 3

Post by wielk »

When I use an NZB to download, first NL freezes for a while, and then the files are put in a cascading series of directories, each containing one file. After about 10 downloads the rest of the files are put in the deault directory (G This is very inconvenient, as RandE does not work. It happens all the time. Downloading with supersearch works fine.

This is what I see in the log:

"16:15:29 * Unable to save file to specified download folder (G:\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries.dvd.german\alt.binaries\). Using default download folder instead."

dr.f10034
Posts: 3
Joined: Tue Nov 06, 2007 8:44 pm

Problems with custom download folders for groups on WindowsHomeServer

Post by dr.f10034 »

Since I am trying to run Newsleecher on WindowsHomeServer I need to specify the all download folders as UNC folders.

So I have set the general download folder to:

\\MY-SERVER\public\Downloads

For 2 newsgroups, a.b.tv and a.b.multimedia I have set custom download folders in the manager tab to:

\\MY-SERVER\videos\Downloads

When I now open a NZB File containing articles from these 2 groups, the download path in the queue gets set to:

\\MY-SERVER\public\Downloads\MY-SERVER\videos\Downloads

So I guess some backslash handling needs to be looked at.

BTW. When I use local links, like D:\shares\public\Downloads , everything works OK, but it is absolutely NOT recommended my Microsoft to directly write or read from the local disc because of the way the Home Server File system is organized.

Thanks

Frank

User avatar
Smudge
Site Admin
Posts: 10034
Joined: Tue Aug 17, 2004 1:42 am

Post by Smudge »

You problem could be the same as the one right above (and in previous pages of this thread) about when importing a NZB file, the directory of the group is being duplicated multiple times.

It could also be a problem with UNC paths. NewsLeecher doesn't have full proper support for UNC paths. Do you have the repeating problem when saving to a local drive? What if you map \\MY-SERVER\public\Downloads\ to a local virtual drive letter?
Please be aware of and use the following pages...
Services Status Page : SuperSearch and Usenet Access server status, retention, server load, indexing time, etc.
Support Request Form : Use this if you have a problem with billing or account status. The forum is only for NewsLeecher application issues.

dr.f10034
Posts: 3
Joined: Tue Nov 06, 2007 8:44 pm

Post by dr.f10034 »

I will try that, that is actulla a good hint.

But the UNC paths do work on NZBs, that do come not from "special groups" and where the default download path is used.

EDIT: I tried using mapped drive letters as substitutes and this seems to work now. Thanks for the workaround

pzam
Posts: 179
Joined: Fri Jul 18, 2008 8:34 pm

alt.binaries.multimedia.vietnamese gives bug 9ii3ks(2)

Post by pzam »

alt.binaries.multimedia.vietnamese gives bug 9ii3ks(2)


I added this group and when I click it on the list it gives this error. I also had max days set to 1. This seems to happen more with this group. Also If I leave it leeching after a while ...
The <articles tab>/[subject] window will eventually go blank, then clicking any group will not show data. I have to exit and restart newsleecher.


Bug Data1:
9ii3ks(2)

Bug Data2:
Invalid argument to date encode

E-Vix
Posts: 1
Joined: Sun May 31, 2009 10:10 pm

Post by E-Vix »

When downloading articles that don't have any PAR or PAR2 files it won't show up in R&E, and when the files are finished they won't be extracted. I've experienced this with loose rar's (articles with only 1 rar file), and with complete sets with an sfv.

User avatar
Smudge
Site Admin
Posts: 10034
Joined: Tue Aug 17, 2004 1:42 am

Post by Smudge »

E-Vix wrote:When downloading articles that don't have any PAR or PAR2 files it won't show up in R&E, and when the files are finished they won't be extracted. I've experienced this with loose rar's (articles with only 1 rar file), and with complete sets with an sfv.
RnE needs par2 files in order to verify the files. If the post doesn't include them, the files will not be added to the RnE list therefore they will not be extracted.
Please be aware of and use the following pages...
Services Status Page : SuperSearch and Usenet Access server status, retention, server load, indexing time, etc.
Support Request Form : Use this if you have a problem with billing or account status. The forum is only for NewsLeecher application issues.

User avatar
bex
Posts: 32
Joined: Fri Oct 14, 2005 5:47 pm

change destination

Post by bex »

change destination in repair and extract does not work correctly if you select more than one item only the on first is the destination changed

Lebowski
Posts: 25
Joined: Thu Nov 30, 2006 4:52 am

Post by Lebowski »

Sometimes it just won't connect. The stuff sits in the queue, was working fine a second ago, but then nothing. I click close, nothing, it just won't do anything. The program just sits there like a retarded child. Finally kill the process, and restart the program, and everything that isn't disabled(to be 'implemented in a later release, grrr) works.
I think I'm just going to go back to 3.9 until stuff works.

chromium
Posts: 54
Joined: Wed Nov 10, 2004 3:23 am

Post by chromium »

4.0 beta 3 is the buggiest POS version of Newsleecher ever. I'm amazed that 4.0 beta 4 isn't out yet.

I have had so many issues, with the NZB recursive folder issue being the worst. The latest issue is my downloads keep stopping.
I queued up a bunch of files, started the download, checked it 2 hours later and the download was just hanging. I disconnect and reconnect and it starts up again for a couple of minutes and then just hangs again.

crocolord
Posts: 133
Joined: Mon Jun 27, 2005 11:55 pm

Post by crocolord »

Wow I think I ran into a nasty one. I had a selection of files in my queue that were in there as leech-paused from the group I was in. One of the files was apparently an nzb that pointed at the files that were already there. It super freaked out when it tried to parse the nzb and re-add the files that were already there. At this point I can't get NL to start. It hard crashes after complaining about dup files. The nzb is already out of the monitored directory so it seems like it's trying to reload the old queue and is trying to merge the list from elsewhere.

loracweb
Posts: 5
Joined: Wed Nov 03, 2004 11:32 pm
Contact:

Post by loracweb »

The unofficial forum release is still the most stable / usable. I have tried all the other betas (including the post beta 3 version) and they all suck. Sure they work for a bit, but they either crash or download to the incorrect location. The post b3 version tends to lockup after a period of time, making it quite useless. The others and their nzb issues make them highly annoying to use.

Sebastiii
Posts: 17
Joined: Wed Aug 17, 2005 5:14 pm
Location: France

Re: Slow Startup

Post by Sebastiii »

SanderDolphin wrote:I load the application and it takes about 30 seconds before it responds. If I click on it before this time, I get NewsLeecher v4.0 Beta 3 (Not responding) in the title.
Hello, the same here ! it was appear with 4.xx version.
Working ok in V3

Version: 4.0 B3
Operating System w/ Service Pack Version: Windows 7 7127
Installation Method: Upgrade
Type of Installation: Registered
Number of Servers: 1
List your provider(s)? Giganews
List of antivirus/firewall software installed: Kaspersky
Connections per server: 20
Server priority: normal
Sebastiii, i love software with minor bug lol :)

User avatar
Core_F
Posts: 156
Joined: Sun Nov 16, 2003 6:51 pm
Location: Germany
Contact:

Post by Core_F »

The par files seem not to be grouped with the original set of rar files. That gives us two problems:

1. The queue list is messy
2. The cleanup button seems to delete paused par files, even if the grouped download of the associated rar files are still in queue
··· Logic Is The Faith Of The Future ···

Post Reply