NL 4 Beta 3 continually crashing with Argument out of range error

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
Post Reply
delta7
Posts: 13
Joined: Wed Sep 22, 2004 11:31 pm

NL 4 Beta 3 continually crashing with Argument out of range error

Post by delta7 » Thu Jun 11, 2009 2:05 am

Hi,

Everything was generally working fine with beta 3 but today after I used Leech Smart to add some items to the download queue I got the following error:

Bug Data1:
wqewq:: 0 :: 0 :: 24

Bug Data2:
Argument out of range

Sometimes the last number is 26 instead of 24

The bug continually appears and the only way to stop it is to close newsleecher. If I then re-open newsleecher the bug appears as soon as I try to connect to start leeching. If I don't connect, the bug does not occur.

I have removed the new entries from the queue but that has not fixed the problem.

Is there any known fix for this problem?


This seems to be similar to the post below that has no answer:

viewtopic.php?p=89351#89351

I am using win xp SP 3.

Thanks

delta7
Posts: 13
Joined: Wed Sep 22, 2004 11:31 pm

Post by delta7 » Fri Jun 12, 2009 2:18 am

Hi,

For anyone interested I have fixed the problem as follows:

I purged the articles in every group that I am subscribed to. There were a few groups that failed to purge (I'm not sure if that is a new bug or just a knock on effect of the previous problems) so I unsubscribed to them, shut newsleecher down, started up newsleecher and re-subscibed to those groups.

I then exported every item in my download queue then deleted them all. I shutdown newsleecher and restarted it.

I tried to drag the newly created NZB files into the download queue but they appear to be corrupt, each item is listed in the queue with a size of 1k. I don't think this is a problem with the original item in the queue because before my problems some of the items were in the process of being downloaded. So the problem appears to be due to the importing of the NZB file ... that may have been reported before!

cheers

DuDDits
Posts: 3
Joined: Sat Jun 27, 2009 10:00 am

Same error, but....

Post by DuDDits » Mon Jul 06, 2009 10:03 am

I removed in ....\cacheV4\download queue\... all files, newsleecher error solved :D

delta7
Posts: 13
Joined: Wed Sep 22, 2004 11:31 pm

Post by delta7 » Mon Jul 06, 2009 1:21 pm

For info, this problem is still in the latest beta (5).

I can create it by having several large items with multiple parts in the download queue and then using super search to add a lot of small files e.g. photo images with smart select.

I found that the download queue becomes corrupted. The items at the top of the Queue list will show it downloading and then sometimes items will just stop part way through e.g. at 10% of the file ... newsleecher will then skip to start downloading the next item in the list.

When looking at the bottom of the screen, the description of what file is actually being downloaded by each connection can show a totally unrelated file is actually being downloaded. A variable amount of time later, the bug will occur and report the crash.

As detailed earlier, clearing out the download queue resolves the problem.

turnipy
Posts: 8
Joined: Wed Oct 06, 2004 12:42 am

Post by turnipy » Mon Sep 14, 2009 11:13 am

I got this error in v4.0 Beta 7.

As previously suggested in this thread, deleting all files from:
C:\Users\<username>\AppData\Roaming\NewsLeecher\cacheV4\download queue\

worked for me.

Post Reply