NL freezes regularly..

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
Post Reply
milesbeverley
Posts: 4
Joined: Sat Mar 10, 2007 12:35 pm

NL freezes regularly..

Post by milesbeverley »

I have had the same problem with the last betas. NL seems to download the queue then after 2 mins it freezes. I also get the 30 second freeze on startup and I have only one NIC active.

The problem seems to be related to the number of connections I have. Normally I can use 8 connections however this freezes quite quickly. When I drop the number of connections to 4 it seems to be stable for a little longer however my overall download speed drops. I have just upgrade to Chello 60 fibre and can get about 6Mbps/s. however I need to drop the number of connections to stop NL feezing.

Any ideas? I am running WIndows Vista home on a 3Ghz intel core duo 2 processor. It is a quick machine.

flanders
Posts: 36
Joined: Mon Feb 27, 2006 9:54 pm
Location: France

Post by flanders »

Just a thought here because I have had a similar issue with my computer:
Are you downloading to your Windows disk? because with that many threads and with the speed you are downloading at, plus other access from Vista, then your HD will not be able to follow...

I have solved the problem by installing NL, the data folder, the temp, the download and the extract folders on an external drive and/or another internal drive but the windows one. Now it works great but I try to max my connection speed with as few connections as possible.

You could also try with your current configuration to set your temp folder (location specified in the ini file) to a RAM disk, which will handle the several threads and then copy the resulting file to your download folder in "one thread" which will be less straining for your HD. Problem is that it will require a RAM disk as big as the largest file you will download, and that can be up to 200Mbytes... if youhave that to spare on your RAM then it's working great.
Fl.

milesbeverley
Posts: 4
Joined: Sat Mar 10, 2007 12:35 pm

Post by milesbeverley »

Sounds like good advice. I have changed the download and extract folders through settings. How can I find the .ini file as it isn't in the Newsleecher folder?

flanders
Posts: 36
Joined: Mon Feb 27, 2006 9:54 pm
Location: France

Post by flanders »

It's very easy: create a text file in your NL install folder and rename it to "newsleecher.ini".

Then inside this file you add the following:
dataFolder=X:\NewsleecherV4\Data\
tempFolder=X:\NewsLeecherV4\Temp\
Obviously you can change the paths to whatever you want...

tempfolder is where the parts will be assembled to make the downloaded file. Very good on a ram disk.

datafolder is all your groups/cache/backups and all, so it can be very large (several gigs). Now if you modify this path by creating the newsleecher.ini file, I assume you will have to copy your current data folder's data to the new location. Thing is I have no idea where it is, maybe in your current NLv4 default install folder?

Just in case here is Smudge's explanation - might be clearer than mine...
viewtopic.php?p=88561#88561

milesbeverley
Posts: 4
Joined: Sat Mar 10, 2007 12:35 pm

Post by milesbeverley »

Thanks. Great advice. I am getting sustained high speeds without freezing. I do get the odd "multiple logins not allowed but it doesn't happen that often.

flanders
Posts: 36
Joined: Mon Feb 27, 2006 9:54 pm
Location: France

Post by flanders »

great!

As for the multiple login thing it can happen if you set your max connections to the exact provider's limit. Recently the tech support from my NGs provider adviced me to take max connections -1 or -2(so let's say 10 max connections in NL settings for 12 max allowed by my provider... I actually set it to 4 because it maxes my connection and prevents my system from hogging (firewall checking being a big CPU hogger too)).

Post Reply