NewsLeecher V4.0 Beta 16

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
pzam
Posts: 179
Joined: Fri Jul 18, 2008 8:34 pm

filtered articles unable to select or open

Post by pzam »

Figured this out partly. see below.

I had been doing this earlier and it was working.

When I open articles to some virtual group (may happen on any group.) I paste a few words in "subject filter area" then when trying to select the articles it would not select them all. It only would let me the ones that had avi or mkv as the filename.
It would not let me pick nzb, par2, srr.

I hope this does not continue to happen.

I made no changes since it last worked other than disabling repair and extract. Then start the program par-n-rar and clean up the download folder of all the stuff newsleecher is not educated to do yet.

This happened just after I had done that.

Go to binaries multimedia and try searching for this "he event our" there are 11 articles that show up, but only 6 can be selected.


*******************
I noticed why this was not letting me select those files they were already on the download list and selected. I don't recall putting them there. The strange thing is the files had not been marked as downloaded or to be download on the articles menu. But on the Queue menu they are.
Last edited by pzam on Sun Apr 11, 2010 1:52 pm, edited 1 time in total.

pzam
Posts: 179
Joined: Fri Jul 18, 2008 8:34 pm

tryed to wipe group cache and got this error.

Post by pzam »

after having the previous error I tried to wipe the group cache in that group and now get this error. I will next delete and re add the group and hope that works.

Bug Data1:
lkjaslkjd

Bug Data2:
Access violation at address 0085A84E in module 'newsLeecher.exe'. Read of address 00000000

dsfn
Posts: 1
Joined: Mon Apr 12, 2010 3:34 am

VERY Slow Download Speed. Beta 4 16b

Post by dsfn »

Hi,

With 16b I get very bad download speed which is about half the amount I get with v3.9.

16b: 2.5MB to 5MB max
v3.9: Steady 10MB

I run Windows 7, my ISP is 100MB/100MB fiber connection. Disabled firewall and antivirus without success.

To workaround this problem I have now both versions installed as I'd like to try out the beta a little more before I decide if I like it or not.

Sunfox
Posts: 223
Joined: Sun Apr 09, 2006 5:24 am

Post by Sunfox »

So any feedback of my issue with it not caching incomplete downloads when exiting? Is this the "new normal" or is something else amiss?

I've also noticed with this new version it has an odd tendancy to always save "full sized articles" even if parts are missing. So, for example, if you have a 10mb file and only 8mb worth of parts are available, with v3.9 it would save an 8mb sized file, but with v4.0 it saves a 10mb file, I'm assuming with padding for the missing parts. Perhaps this speeds up PAR correction.

elmariachi
Posts: 14
Joined: Wed Jun 13, 2007 6:22 pm

Files with long names cant be downloaded

Post by elmariachi »

When I try to download files with large names (usually i use the leech smart option) the files get queued properly (in earlier version it would just fail with a strange error). The files get downloaded into the temp folder, but never appear in the actual folder with their actual name.

When I use leech specify and shorten the sub folder name everything works just fine.

The problem is that when using leech smart it starts downloading just fine and often i only realize that it didn't work just before i want to use the files ... big disappointed.

Please fix this. It could be just a warning that the resulting file + folder name exceeds certain limits and for this type of file only leech specify can be used, but please let us know this BEFORE starting to download.

Shun
Posts: 59
Joined: Thu Jan 20, 2005 2:01 am
Location: Tokyo, Japan

Re: Files with long names cant be downloaded

Post by Shun »

I agree that this is a very annoying issue. It would be great to have an option to specify the maximum length for subfolder names. Either that or automatic shortening of subfolder names.

KraZe
Posts: 1
Joined: Thu Apr 15, 2010 8:45 am

Post by KraZe »

thenormal wrote:installed this new beta, it crashes back to desktop as soon as it's launched. The problem is the "connect" button. i set NL to auto-connect to server when the program starts. this causes an immediate crash as soon as i launch the app.....
I was encountering the same problem. When I uninstalled Newsleecher and reinstalled the 4b15 version, I was getting a message that my account had expired. When I renewed my account, then reinstalled b16, the problem went away. Now running 4b16 with no issues.

pzam
Posts: 179
Joined: Fri Jul 18, 2008 8:34 pm

Post by pzam »

Folder name length problem has to do with windows explorer also 8 bit file names.

I have been using UTF-8 file-names so I can store file-names as chars in each language.
The Windows NT/2000/2003/XP/Vista family use two-byte Unicode characters internally but the older Windows operating systems (such as Windows 95/98/ME) didn't support Unicode at all
t
If you connect a machine with 8 bit file name support to you LAN or a Linux machine they handle file names a little different than windows. If you copy or change anything with those machines the file name can change also.

Newsleecher will run into problems with files and folders.
In making folders the most annoying thing was it adding an extension on folders. I think if you turn on the clean up file name option it helped with some name problems. If you have the tweak turned on to not download duplicates that can affect what you get also.

I read Microsoft was patching explorer to better handle long file-names.
If you are having troubles with naming you might check if you have all the latest updates.

Crand
Posts: 44
Joined: Sat Oct 23, 2004 12:52 am

Fix one thing, break a few others

Post by Crand »

For Christ's sake, how long does it take people complaing about this program for you to fix it? Seriously, I want to know.

TRUNCATE FOLDER NAMES TO "X" CHARACTERS <-!!!!!!!!!!!

Also, rename "Adv Nerdy Tweaks" to "Settings". So effing stupid.

User avatar
the doctor
Posts: 250
Joined: Wed Apr 22, 2009 12:40 am
Location: DeLand, Florida USA
Contact:

Minor error in Spelling Help menu - License Key tools

Post by the doctor »

If already licensed and attempt is made to "Register NewsLeecher" (either Normal or Giganews) message that displays has a spelling error uninstall is spelled as unintall (missing the "s").

leifsjensen
Posts: 31
Joined: Wed Mar 21, 2007 10:24 pm
Location: Denmark

Bookmarks

Post by leifsjensen »

I have no idea if this has already been reported.
If you have two book-marks ( for SuperSearch ), one saved with text in the "Result Search" filter and one without, then if you click the one with filter first and then the one without, the filter is not cleared for the seccond search.

TheKiwi
Posts: 2
Joined: Tue Jan 03, 2006 1:45 pm

Post by TheKiwi »

a lot of bugs in this build. For some reason Newsleecher checks drive C and issues a warning saying that it is below the specified download limit (which it is) and pauses the download queue - but I am downloading on a different drive and have all paths set to a different drive. Newsleecher in no way involves that drive.

Also, if you double click on a certain spot to the right on the bottom blue bar you will get a popup box that just says "click". IE double click to the right of the "Total DL:" around the middle in the blank space.

Crand
Posts: 44
Joined: Sat Oct 23, 2004 12:52 am

Post by Crand »

TheKiwi wrote:Also, if you double click on a certain spot to the right on the bottom blue bar you will get a popup box that just says "click". IE double click to the right of the "Total DL:" around the middle in the blank space.
That one is pretty sweet.

User avatar
the doctor
Posts: 250
Joined: Wed Apr 22, 2009 12:40 am
Location: DeLand, Florida USA
Contact:

You need to appologize

Post by the doctor »

Koogle wrote:V4 is a joke.. its so crap, nothing at llt worthwhile has been done to fix and improve things. The most hilarious thing is that options GUI is just a laugh, even 3.9 was better, now you got a crummy sTuff dialog with nerdy tweaks where before you at least had useful ui to to maker quicker changes, this developer is an idiot. Or perhaps its the fools who now use NL Winshi7e user noobs lol
You are referring to a BETA (still in development - even if it is now in release candidate status, it is still a beta testing version).

Why are you being so hostile and rude?

Development is what BETA versions are all about - I use v4 b16 because it has implemented improvements over previous versions. Yes there are items that do not work or are missing - It is still in BETA (test) status. In beta versions things will not work and may be missing.

DO NOT USE THE BETA VERSION IF YOU EXPECT A COMPLETED AND FULLY RUNNING PROGRAM.

Once NL4 is released as a Final release, the points you present will be valid, but not now and never presented in so rude and childish a fashion.

We are all intelligent adults here (at least most of us are) and there is no need to be rude (to everyone) and so childish.

p0W3Rh0u5e
Posts: 176
Joined: Thu Apr 21, 2005 6:46 pm

Post by p0W3Rh0u5e »

I got a problem when i try to redownload a file within a session, it does'nt get written, while the temp-files are there. Restarting NL helps...

Queuing files with identical names still is'nt possible too, i'm not talking about queing the same post multiple times, it's just about different posts with identical filenames/subjects.

Locked