nl70003.ufr4 – R&E gets stuck

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
Post Reply
User avatar
noblemd
Posts: 179
Joined: Tue Jun 15, 2004 3:38 am
Location: Deland,Fl, USA
Contact:

nl70003.ufr4 – R&E gets stuck

Post by noblemd »

Don't know whether this is been reported before – searched for Repair and Extract, repair, extract, stuck, frozen and various combinations – could not find any related forum posts.

nl70003.ufr4
Windows 8.1

R&E gets stuck – R&E line turns red – size indicates 0 KB – status indicates ???

Everything else – file name and + expansion information reads normally – initial information only.

Unknown cause – happens frequently – usually when downloading a number of video file posts at one time.

Image

BTW: after restarting NewsLeecher, R&E repairs and extracts properly.
Last edited by noblemd on Fri Dec 12, 2014 9:09 pm, edited 3 times in total.
Windows 10 v.2004
Ryzen 3950 (16 Cores 32 Threads - OC 4.0 GHz)
DeepCool Captain 240 RGB V2, AIO Liquid CPU Cooler (Max Temp 75°C 100% load)
NL download drive: M2 2280 500 GB NVME SSD (2.5 GB/s r/w)
Synology NAS #1: 32 TB RAID 5 (5 x 8 TB Drives)
Synology NAS #2: 18 TB RAID 5 (4 x 6 TB Drives)
500 Mb/s Internet Connection (NL Avg D/L speed 55 MB/s)

quickly
Posts: 107
Joined: Mon Sep 12, 2005 4:00 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by quickly »

confirmed.
happened here too. not always, but sometimes. manually paring and unraring works without problems.

User avatar
noblemd
Posts: 179
Joined: Tue Jun 15, 2004 3:38 am
Location: Deland,Fl, USA
Contact:

Re: nl70003.ufr4 – R&E gets stuck

Post by noblemd »

Update: it is not necessary to delete PARs to get R&E working again. Restarting NewsLeecher clears the problem.

Don't know if this is speed related - my connection speed is 125-150Mbps.

Additional images – this happened this morning when I launched NL. SuperLeech began downloading the posts.
R&E got stuck.

Image

Image
Last edited by noblemd on Mon Dec 01, 2014 10:50 pm, edited 2 times in total.
Windows 10 v.2004
Ryzen 3950 (16 Cores 32 Threads - OC 4.0 GHz)
DeepCool Captain 240 RGB V2, AIO Liquid CPU Cooler (Max Temp 75°C 100% load)
NL download drive: M2 2280 500 GB NVME SSD (2.5 GB/s r/w)
Synology NAS #1: 32 TB RAID 5 (5 x 8 TB Drives)
Synology NAS #2: 18 TB RAID 5 (4 x 6 TB Drives)
500 Mb/s Internet Connection (NL Avg D/L speed 55 MB/s)

#1tech
Posts: 46
Joined: Mon Oct 13, 2014 10:42 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by #1tech »

I am seeing the same problem with the nl70003.ufr4.
My download speed is around 10Mbps from usenet servers.
It seems to always be the last video file in the Queue list.
No matter what you try to do to clear the red highlighted file it just won't go away :!:

Then I just close NL and restart it and the download will finish.
Would be nice to know what that red highlight on the queue file means :?:

Sunfox
Posts: 223
Joined: Sun Apr 09, 2006 5:24 am

Re: nl70003.ufr4 – R&E gets stuck

Post by Sunfox »

I reported this about a month ago with no confirmation from anyone:

viewtopic.php?f=9&t=25719

As far as I know, it's triggered specifically by queuing multiple entries at once, or more specifically, when multiple PARs are downloaded and added to the RnE queue in quick succession.

In addition to the one red line that hangs everything, other problems include falsely thinking that one of these brand new RnE entry is instantly complete, and actually deleting all of its articles from the download queue - which prevents it from being downloaded at all.

#1tech
Posts: 46
Joined: Mon Oct 13, 2014 10:42 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by #1tech »

Changing the way NL downloads Superleech query hits might help............

When you turn on NL, and the Superleech function is active, all items in the list are searched for at the same instant. If the list is long and all these items are searched for at the same time could be causing the bottleneck in the download queue. My suggestion would be to automatically stagger the Superleech search list timing.

Having the Superleech programing delay the search for each item in the Superleech list by 10 or 15 seconds would enable the items to load the download queue "one at a time". This would avoid any bottleneck that occurs when all Superleech items are searched for all at the same time as happens in the latest beta, nl70003.ufr4.

Also, it would probably help the News-Servers by not hitting them with all those requests at the same instant!

:idea:

Sunfox
Posts: 223
Joined: Sun Apr 09, 2006 5:24 am

Re: nl70003.ufr4 – R&E gets stuck

Post by Sunfox »

This isn't actually a Superleech issue. I'm not using that and I have the same issue. It's an issue with items quickly being added to the RnE queue, and also how RnE manages the download queue.

allright
Posts: 9
Joined: Sat Mar 10, 2012 8:08 pm
Location: Danmark

Re: nl70003.ufr4 – R&E gets stuck

Post by allright »

Yeah, RnE is very buggy in this release, sometimes after extracting I experince that it doesn't delete the files, instead it marks the next item on the list as extracted without doing anything other than deleting the password - we could use a quick update, but it has been very quiet for the last month.

User avatar
noblemd
Posts: 179
Joined: Tue Jun 15, 2004 3:38 am
Location: Deland,Fl, USA
Contact:

Re: nl70003.ufr4 – R&E gets stuck

Post by noblemd »

No, it's not a SuperLeech issue – it is an R&E issue which occurs when a large number of (10 or so) headers are selected for download at the same time. R&E seems to get overwhelmed and becomes stuck.

It occurs most often when SuperLeech finds a number of new headers to download. It also occurs during manual header download selection as well.
Windows 10 v.2004
Ryzen 3950 (16 Cores 32 Threads - OC 4.0 GHz)
DeepCool Captain 240 RGB V2, AIO Liquid CPU Cooler (Max Temp 75°C 100% load)
NL download drive: M2 2280 500 GB NVME SSD (2.5 GB/s r/w)
Synology NAS #1: 32 TB RAID 5 (5 x 8 TB Drives)
Synology NAS #2: 18 TB RAID 5 (4 x 6 TB Drives)
500 Mb/s Internet Connection (NL Avg D/L speed 55 MB/s)

Sunfox
Posts: 223
Joined: Sun Apr 09, 2006 5:24 am

Re: nl70003.ufr4 – R&E gets stuck

Post by Sunfox »

I've done testing... it's more likely to happen when you select something like 10 (in fact, pretty much guaranteed), but then I started selecting 5 at a time and it happened... then 3 at a time and it happened. I've even had it happen doing single selections very quickly. It's definitely something aggravated by having multiple entries being added almost simultaneously, though.

#1tech
Posts: 46
Joined: Mon Oct 13, 2014 10:42 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by #1tech »

One thing that could be done as I stated in the "Wish List for Santa Forum", Topic from Wed. Dec. 3, 2014"Automatically Stagger Superleech Queu List Search Timing". would help when the SuperLeech Query List finds a group of files to download at the same instant to the R&E Tab. Delaying all the SuperLeech List Queries from each other by 10 to 15 seconds would break up any bottleneck from the SuperLeech Query List of simultaneous transfers to the R&E Tab. That could solve part of the R&E issue. :idea:

#1tech
Posts: 46
Joined: Mon Oct 13, 2014 10:42 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by #1tech »

Oh Yea, I also got the Solid Red Line Entry [at the bottom of the R&E list] this afternoon when "SuperLeech dumped 7 files to the R&E Tab at the same instant. Everything stopped and I had to close and restart NL to clear the problem.

Sunfox
Posts: 223
Joined: Sun Apr 09, 2006 5:24 am

Re: nl70003.ufr4 – R&E gets stuck

Post by Sunfox »

Again, SuperLeech is not the problem. This same problem also triggers from SuperSearch and even importing multiple NZB files. Your solution would merely be trying to address the symptom, but not the actual cause - which is that something with RnE is broken in V7 that wasn't broken in any previous version. This was never a problem before - I could load hundreds of PAR2 files as fast as the system could process them before, now it chokes on even 3 at a time.

#1tech
Posts: 46
Joined: Mon Oct 13, 2014 10:42 pm

Re: nl70003.ufr4 – R&E gets stuck

Post by #1tech »

OK!

Post Reply