Page 1 of 1

V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Mon Dec 09, 2019 12:26 am
by nurbles
I was browsing the settings in 8.0 Beta 3, trying to see if I could be the reason that the New24 and Raw06 searches never return any results when I found this:
missing.png
missing.png (63.54 KiB) Viewed 5248 times
Did you notice the small line of heiroglyphics that is centered a little below "Max Download Speed"? I am guessing that there may be a setting there, but what it might be eludes me.

FWIW, this is running under Windows 10 with the display scale set to 150%.

I checked the other settings pages and this was the only one with something obviously cut off. It is possible that something is ENTIRELY missing from one or more other pages, but I have no way to know that.

Re: What setting is missing here?

Posted: Mon Dec 09, 2019 10:09 pm
by noblemd
Edit -removed

Re: What setting is missing here?

Posted: Tue Dec 10, 2019 10:49 am
by nurbles
I am asking about the marks above the phrase "it is possible" and below the words "Max Download Speed". Those are most certainly NOT ellipsis. They appear to be text that was clipped. If it is not useful or important, why is it there? If it IS useful or important, why can I not see it?

Re: What setting is missing here?

Posted: Tue Dec 10, 2019 1:46 pm
by Spiril
nurbles wrote:
Mon Dec 09, 2019 12:26 am
Did you notice the small line of heiroglyphics that is centered a little below "Max Download Speed"?
That text shouldn't be there at all. I'll delete it for the next release.
nurbles wrote:
Mon Dec 09, 2019 12:26 am
I was browsing the settings in 8.0 Beta 3, trying to see if I could be the reason that the New24 and Raw06 searches never return any results
That's strange. What does the text in the lower left corner of the SS listview say, after you have performed a "Raw06" search?

Does it say "No search matches were found" - or something else?

Re: What setting is missing here?

Posted: Tue Dec 10, 2019 3:21 pm
by noblemd
nurbles wrote:
Tue Dec 10, 2019 10:49 am
I am asking about the marks above the phrase "it is possible" and below the words "Max Download Speed". Those are most certainly NOT ellipsis. They appear to be text that was clipped. If it is not useful or important, why is it there? If it IS useful or important, why can I not see it?
Ah, I see them on your pic now - so small I did not realize that's what you were refering to - they do not appear in my NL v8b4 UFR 2 Download Settings dialog.

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Tue Dec 10, 2019 5:53 pm
by Seeker04
nurbles wrote:
Mon Dec 09, 2019 12:26 am
I was browsing the settings in 8.0 Beta 3, trying to see if I could be the reason that the New24 and Raw06 searches never return any results when I found this:
missing.png
Did you notice the small line of heiroglyphics that is centered a little below "Max Download Speed"? I am guessing that there may be a setting there, but what it might be eludes me.

FWIW, this is running under Windows 10 with the display scale set to 150%.

I checked the other settings pages and this was the only one with something obviously cut off. It is possible that something is ENTIRELY missing from one or more other pages, but I have no way to know that.
Do to your Font and Display Scale you are missing the wording that is below "Max Download Speed". This is from my Windows 7 32bit OS, and from my NL V8 Beta4 UFR2:

"By applying this setting, it is possible to limit the maximum speed at which Newsleecher is downloading files - either manually or by the built-in "Speed Scheduler"."

Re: What setting is missing here?

Posted: Tue Dec 10, 2019 11:38 pm
by nurbles
Spiril wrote:
Tue Dec 10, 2019 1:46 pm
nurbles wrote:
Mon Dec 09, 2019 12:26 am
Did you notice the small line of heiroglyphics that is centered a little below "Max Download Speed"?
That text shouldn't be there at all. I'll delete it for the next release.
nurbles wrote:
Mon Dec 09, 2019 12:26 am
I was browsing the settings in 8.0 Beta 3, trying to see if I could be the reason that the New24 and Raw06 searches never return any results
That's strange. What does the text in the lower left corner of the SS listview say, after you have performed a "Raw06" search?

Does it say "No search matches were found" - or something else?
It always says "No search matches found" and it says that VERY quickly. I just figured that the back end wasn't actually implemented yet.

Re: What setting is missing here?

Posted: Wed Dec 11, 2019 6:56 am
by Spiril
nurbles wrote:
Tue Dec 10, 2019 11:38 pm
It always says "No search matches found" and it says that VERY quickly. I just figured that the back end wasn't actually implemented yet.
That's strange. It's fully implemented, so it should work wo. issues.

After performing a Raw06 search, does the NewsLeecher log contain any error messages?

Other SuperSearch queries return results right?

Do you have the "Search Append"-filter disabled? It's located at "Settings->SuperSearch->Search Append Filter".

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Wed Dec 11, 2019 4:38 pm
by noblemd
Ah Ha - Disabling Search Append Filter worked.

There should be a message warning about Disabling Search Append Filter when pressing New24 or Raw06.

And... MinKb: etc. search filters should be enabled to work with Raw06.

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Wed Dec 11, 2019 5:32 pm
by Spiril
noblemd wrote:
Wed Dec 11, 2019 4:38 pm
Ah Ha - Disabling Search Append Filter worked.

There should be a message warning about Disabling Search Append Filter when pressing New24 or Raw06.
Yea it's a bug. I'll make sure New## and Raw## works with the append filter and all the other query filters/tags.

When implemented, I will post a test release here.

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Wed Dec 11, 2019 10:12 pm
by noblemd
Did not realize it was an undocumented feature! :shock:

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Fri Dec 13, 2019 1:16 pm
by Spiril
This forum test release should make "new##" and "raw##" compatible with the search append filter and all the valid search query params.

https://www.newsleecher.com/nl80004.ufr5.exe

Re: V8.0 Beta 3 - Raw06 / New24 not returning any results.

Posted: Sat Dec 14, 2019 2:19 pm
by nurbles
Sure enough. I had an append filter defined and when I turned it off, Raw06/New24 started working. Thanks for the tip.

Re: V8.0 Beta 3 - Raw06 / New24 - Fixed in v8b4 UFR 5

Posted: Sat Dec 14, 2019 5:24 pm
by noblemd
v8b5 UFR 5

Raw06 / New24 - WORKING with append filter ENABLED.