8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Forum to report beta release bugs and discuss the latest beta releases with other users.
• If reporting a beta release bug, be sure read the bug reporting guidelines first.
Forum rules
IMPORTANT : Be sure to read the NewsLeecher forums policy before posting.
Post Reply
Posts: 34
Joined: Mon Apr 30, 2018 10:36 pm

8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by nurbles » Tue Dec 31, 2019 11:28 am

When downloading article (sets) that have already been (incorrectly) marked as spam, NL starts giving me this message and effectively reducing my download speed from its normal 120Mbps to around 45-50Mbps.

This is NOT a drive issue, since NL can often download many, many GB of data at full speed with no issues at all. I ONLY see this issue when I have forced it to continue downloading something it has marked as spam (in conflict with my spam detection settings [reported in another post]).

I have tried stopping and restarting NL with no success. As soon as it starts one of the forced 'spam' downloads, it starts complaining.

User avatar
Posts: 158
Joined: Tue Jun 15, 2004 3:38 am
Location: Deland,Fl, USA

Re: 8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by noblemd » Wed Jan 01, 2020 4:28 pm

No problem with SPAM detected files, but see below...

As a test, turned on all spam detection and downloaded a file I knew would be detected - and it was - NO slow down occurred - downloaded without pausing except when the warning occurred and after clearing the spam dialog, d/l continued without pause.

Just the other day I built a new system (Ryzen 3950x). As part of that build I decided that using the entire 512GB Intel M2 SSD for NL data/downloads was not necessary (don't normally download more than max of 40 or 50 Gb at one time - files are unpacked to a different drive - so, why use the whole drive?).

Note: The NewsLeecher Data/Temp directory is on this drive (designated as "W:") and my default download (contents of newsleecher.ini in program folder below) points to this drive. The slot for the M2 drive is an Ultra M2 - meaning it is capable of 32 GB/sec transfer speeds and the drive itself is rated at 1000 to 1500 Mb/sec read/write speeds.

Contents of C:\Program Files (x86)\NewsLeecher\newsleecher.ini:


After repartitioning the Intel M2 with 2 equal partitions (1st partition became my boot drive), I began to have the same problem you are describing. This problem was directly attributable to the repartitioning of the drive and using one of the partitions as the boot drive. As soon as I made the drive one partition again (data only), the problem went away. I download at 55 MB/sec. with no interruptions. The Ryzen 3950x runs programs very fast (16 cores, 32 threads) and writing to the M2 drive keeps up with no interruptions.

In my case, the slight alteration of the data drive was enough to reduce drive access speeds and cause the slow down - even with a drive that has very fast read/write speeds.

Electromechanical HDDs are the slowest data device in your computer.

What drive are you using for your data drive (make, model, and type)?

Is it a separate drive or the OS boot drive (default settings)?

What version of Windows?

Are any TSRs (Terminate and Stay Resident) running in the background slowing drive access during spam detection?

I have entered Performance Exclusions into my virus detection software telling it to NOT monitor the NL Program, Data & download folders (it still monitors the unpack folders). If the downloaded files are being scanned/detected by your virus software it could slow down writing files - those types of files would be prime candidates for scanning.

Not saying that the problem is something on your end, but I don't get the same problem with spam detected d/ls - Could (at your d/l speed) still be something NL is doing.

BTW: The spam/download test was done on and I'm now using a fresh install of NewsLeecher - not an upgrade from v7. I am not getting the error dialogs that popped up constantly while using the upgrade install.
Windows 10 v.1909
New computer build: Ryzen 3950 (16 Cores 32 Threads - OC 4.5 GHz)
NewsLeecher download drive: M2 2280 500 GB SSD (1.2 GB/s r/w)
Synology NAS #1: 32 TB RAID 5 (5 x 8 TB Drives)
Synology NAS #2: 18 TB RAID 5 (4 x 6 TB Drives)
500 Mb/s Internet Connection
Avg. NewsLeecher D/L speed 55 MB/s

Posts: 4
Joined: Sun Jan 05, 2020 11:10 am

Re: 8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by scuba966 » Sun Jan 05, 2020 11:12 am

I do as well have issues iwth the temporarily pausing but NL freezes for me and I have to kill the task, this is happening at least every other hour especially when downloading multiple files in the queue.

Posts: 34
Joined: Mon Apr 30, 2018 10:36 pm

Re: 8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by nurbles » Mon Jan 06, 2020 12:56 am

I don't know all of the technical performance details for the drive (D:) NL is configured to write to (which is also configured as the drive where the Windows temp folder is located), but here is its name/description:

Seagate Desktop SSHD ST4000DX001 4TB 64MB Cache SATA 6.0Gb/s 3.5" Solid State Hybrid Drive

I am running Windows 10 Home (64 bit) on an intel Core i7-6700K CPU @ 4.00GHz with 32GB RAM. The Windows C: drive is a Samsung EVO SSHD, so it should definitely not be slowing anything down. I disabled all Unpacker functions as soon as the problem started, but THAT didn't help either.

However, what I would need explained is why there are no problems at all for days, or weeks, download tens or sometimes even hundreds of GB with not one single problem, but sometimes NL reports that the drive cannot keep up with 50% of my normal download speed.

I thought re-download things detected as spam was the trigger, but I guess that was wrong, sorry. In my defense, I tried adding another file to the download queue, and moved it into second place and it downloaded as full speed, with no issues about waiting for the output drive. Then the next (re-downloaded spam) file started and the issue was back. Hopefully you can see why I think there is a relationship.

I have verified that nothing else is "getting in the way" and the NL is the program using almost all of the CPU, Drive I/O and Network I/O occurring on the system (though the overall system is about 95% idle!) This is why I am so confused.

My final useless thought: As a programmer myself, my first thought would be a thread synchronization issue within NL and those can be a real bitch to track down, but they often cause issues just like this when they are almost correct.

Posts: 3
Joined: Mon Jan 06, 2020 1:25 pm

Re: 8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by lunadmin » Mon Jan 06, 2020 1:41 pm

i have the same issue but the more bad thing is when it hangs on the process " Temporarily paused while writing downloaded data to storage device" that happens really often compared with an Error message "File not found" - then i must crash the process and starting again, and again and again.

Well this issue exist on the Final Release to, it depends on the downloading files, some will trigger that issue others not - with the freezing.

This normal temorary pausing, must be an issue in the engine, decoding and writing from the Temp to the Download Folder (the ssd has enough performane for that) but with a RAM Drive as Temp Folder, this Issue does not exist. The Freezing and hanging does occur in every case.

For now there should be a setting to move the Temp folder to different location, (the temp folder in den ini files are not used), that could help a lot!

User avatar
Posts: 30
Joined: Wed Dec 04, 2013 11:59 pm

Re: 8.0 Beta 4: Temporarily paused while writing downloaded data to storage device

Post by Blakeyrat » Mon Jan 06, 2020 2:56 pm

I have had this problem also. It seems to happen if I add a lot of files to the download que. Everything is fine for a while but them NL stops and says "Temporarily paused while writing downloaded data to storage device".

And that's it. At that point you can't so anything, can't even exit. I have to use task manager to kill NL.

Post Reply